Translations are not saved

This forum provides support and discussion about the 2.1 release of Joom!Fish only. Please be aware that JoomFish 2.1 is no longer the latest, public release of JoomFish. Consider upgrading to 2.2 if you find any particular issue.
Forum rules
Please visit the Documentation section first. Especially take a look at the Installation issues and the FAQ document.

Before posting, don't forget to search the forums.

If you still have issues, start a topic and include as much information as possible:

First of all, check if you are running the latest available version of Joomla! (1.5.23) and Joom!Fish (2.1.7). Posts for issues, where both systems are not updated, will be ignored.

We need the following at least (you can find this in your Joomla! backend under help > system info):

* PHP version (e.g. 5.2.5). Note: The support for PHP4 is discontinued.
* Joomla! version
* Joom!Fish version
* Web Server software (Apache or IIS with version number if possible)
* Server Operating system (e.g. Linux, Windows, Solaris, Darwin ...)
* Webserver to PHP interface (e.g. apache2handler, cgi-fcgi)
* Database version
* memory_limit from your phpinfo

Please enable error reporting and include any error messages in your posting.

Finally, please describe the steps required to recreate the problem and also please enable error reporting and give us any error messages generated.

Re: Translations are not saved

Postby Catfish on Sat Jan 28, 2012 2:24 am

I have no solution for the 404 message problem, but the solution I posted earlier definitely works for the problem where you translate and save and the article still is empty afterwards.
Catfish
Newbee
 
Posts: 45
Joined: Thu Jun 24, 2010 4:05 pm

Re: Translations are not saved

Postby WINEMAN on Sat Jan 28, 2012 5:49 am

Alex still hasn't weighed in on this problem?
WINEMAN
Newbee
 
Posts: 45
Joined: Wed Oct 28, 2009 4:34 am
Location: Japan

Re: Translations are not saved

Postby pipfrosch on Wed Feb 01, 2012 1:07 am

I have the same problem : (

If I edit an article in the database, the text is shown in JF. Then I change the text to something different, click save and everything is gone...

Changing the editor from "JCE" to "TinyMCE" or "No Editor" has no effect.

The problems occure since my update from Joomla 1.5.15 / JoomFish 2.0.2.

Current system:
Joomla 1.5.25
JoomFish 2.2.3
JCE 2.0.20
PHP 5.3.3
Apache 2
MySQL 5.1.49
Memory limit 128MB
Debian 6

If someone of the developers need access to my page I can provide!

Please help!!!

Best regards, philip
pipfrosch
Newbee
 
Posts: 1
Joined: Wed Feb 01, 2012 12:49 am

Re: Translations are not saved

Postby Catfish on Wed Feb 01, 2012 1:35 pm

just read the thread and you'll find the solution that I posted earlier. If I were you I would not wait for the Joomfish team to solve that problem.
Catfish
Newbee
 
Posts: 45
Joined: Thu Jun 24, 2010 4:05 pm

Re: Translations are not saved

Postby Catfish on Fri Feb 03, 2012 3:29 pm

WINEMAN wrote:Alex still hasn't weighed in on this problem?

I sent him PMs a long time ago, no reaction whatsoever. You would think that now the problem is identified, they'd fix it maybe in an update, but obviously they are not interested.
Catfish
Newbee
 
Posts: 45
Joined: Thu Jun 24, 2010 4:05 pm

Re: Translations are not saved

Postby ericz on Fri Feb 03, 2012 5:24 pm

I don't think that it is not the question if Alex is interested or not; the point is that there are a lot of things that need to be done.
ericz
Newbee
 
Posts: 14
Joined: Thu Jan 19, 2012 9:11 pm

Re: Translations are not saved

Postby Catfish on Fri Feb 03, 2012 5:31 pm

that is total BS. This thread exists for a very long time already, the problem in question affects dozens of users, and it is clearly related to a fault in Joomfish; and there has been zero contribution on this issue from the Joomfish team. Not even a line like "we are trying to fix this" - pretty telling I dare to say.
Catfish
Newbee
 
Posts: 45
Joined: Thu Jun 24, 2010 4:05 pm

Re: Translations are not saved

Postby WINEMAN on Sat Feb 04, 2012 6:18 am

This problem may be a two-part solution involving existing articles vs. future articles.
I'm no programmer but it seems that a combination of Gofry's (future articles) and Catfish's (existing articles) hacks might be the solution.

Is anyone using both successfully?

I applied Gofry's code hack today and will try a few new entries today just to check it out.
I don't have too many articles with translation problems right now so I won't need Catfish's solution just yet.

Will try to report back next week with results.

A real shame that we haven't heard from the JoomFish team on this yet. Even though, I know they're busy with several versions of Joomla. :(
WINEMAN
Newbee
 
Posts: 45
Joined: Wed Oct 28, 2009 4:34 am
Location: Japan

Re: Translations are not saved

Postby quodo on Sat Feb 04, 2012 1:53 pm

I find it nearly impossible to try to fix something that I cannot reproduce on my own system. That's why I find answers to the questions in the pink box saying "Forum rules" so important, especially the steps how to recreate the problem.

From all the problems that are mentioned in this thread I can now reproduce one of them on JoomFish 2.2.3 (and it took me a while after I incidentally encountered the problem to be able to reproduce it for translations that saved well, e.g. getting this problem on purpose):
- Only when translating "Contents" (Translation menu, set Language to my second language (Dutch), set Content Element to Contents, click the Title of an article to translate)
- If, at some point, either
(a) an article has been saved with a truly empty introtext (e.g. not even the "<p> </p>" that for example the WYSIWYG editor may insert) or
(b) the Article Text is truly empty (check with the WYSIWYG editor toggled off) and then save,
then the article text will never be saved ok

Reproduce
Delete Article Text, check there is really no contents with the WYSIWYG editor toggled off, then save the article, then try to save any Article text, with or without Readmore: it won't save correctly.

Solution
Delete the translation(s) with problems: Backend > Components > JoomFish > Translation > [Select the translation(s) with problems] > Click Delete on the toolbar. And start translation again (but always with text before the Readmore line or when there is no Readmore: some text in the article).

To be able to save the article even without any text, or without a truly empty introtext (this is: really nothing before the Readmore line that is "<hr id="system-readmore" />" when the WYSIWYG editor is toggled off), apply the solution gofry proposed here: viewtopic.php?f=47&t=8375&p=35301#p35469

I don't think this is the perfect solution, there's probably more to it, but I'd think that's a subject for the Tech-Talk... and this works for the problem that I could reproduce on my system.

And I'd say it's very much possible that in this thread there are multiple problems. I've read the entire thread multiple times now, and from some posts I think the above steps will help, and for some posts I think there might be something else going on, but then there is no info on JoomFish version, and never information on how to reproduce a problem, so there is no way (at least for me) to find a cause.

For any other user for whom the above things don't work, the question will be: what is different in what you are doing or what is different on your setup?

My system and setting details
    - Joomla 1.5.25 (currently latest version)
    - JoomFish 2.2.3 (currently latest version; upgraded from 2.0.4 via 2.1.7), second language: Dutch (nl-NL)
    - PHP 5.2.9 / Database MySQL 5.1.3 / Apache 2.2.1 (on Windows (Xampp)) / Browser: Mozilla Firefox 3.6.26
    - Editor TinyMCE (as came with Joomla)
    - Debug System: Yes / Error Reporting: Maximum
    - memory_limit 64M
    - No error messages from Error Reporting.
Note: I only tried to translate things in the Backend, not in the Frontend.
quodo
Contributor
 
Posts: 568
Joined: Wed Feb 03, 2010 3:08 pm

Previous

Return to Joom!Fish 2.1.x Core Extension [deprecated]

Who is online

Users browsing this forum: Bing [Bot] and 3 guests